Repair or dump Original SIM2K-250

Discussion in 'Chiptuning' started by AutomotrizVIP, 1 September 2019.

  1. AutomotrizVIP

    AutomotrizVIP ATZ Regular New Member Valued Contributor

    Hi mate, I have ecu damaged by others, I would like to be able to repair,this car doesn't bring immo, map error, cs, crc.
    Ref ecu:
    P/N 39130-2GKD5, 39100-2GKD5
    A2C9798170101_ CONTINENTAL_DMDGGEMA5A
    SIM2K-250_ Tricore
    TIP CAR:
    Hyundai Santa fe GLS PREMIUN GDI 2016
    TYPE OF BOX:
    Automotic_ ( A/T ), Gasoline
    CYLINDERING: 2.4L 4WD (2.359)
    VIN: KMHSU81BDGU591609
    Bad read file......
    USE K-TAG.
    Thank you very much in advance.
     

    Attached Files:

  2. Shooting

    Shooting Super Moderator Staff Member

    What's this file from?: "santafe mapas 2016 abdul.bin" .. Is this an OBD read?

    wbr
     
  3. AutomotrizVIP

    AutomotrizVIP ATZ Regular New Member Valued Contributor

    Abdul says, because it was read with MagicProg, thinking that K-tag could not read map, to verify.
     
  4. Shooting

    Shooting Super Moderator Staff Member

    K-Tag doesn't read Tricore well, it will be corrupt, where is Original?

    wbr
     
  5. AutomotrizVIP

    AutomotrizVIP ATZ Regular New Member Valued Contributor

    [QUOTE = "Shooting, post: 2857, member:

    wbr [/ QUOTE]
    It is the original read. with 2 original ktag master teams and magicprog.
    As the first Post, Repair OR original dump says. for this vehicle, since there are many different cars. with a similarity in the Ecu.
    This ecu was damaged by other colleagues in the area. leaving the car dead....
     
    Last edited: 1 September 2019
  6. AutomotrizVIP

    AutomotrizVIP ATZ Regular New Member Valued Contributor

    IMG-20190822-WA0116.jpeg The file that is in the Bank of Ktag is for a mechanical Hybrid 2.0, In New trasdata There are no files, in Magic I found for a similar ecu but it does not apply since it is for an Elentra
     

    Attached Files:

    Last edited: 1 September 2019
  7. Shooting

    Shooting Super Moderator Staff Member

    Your picture is not in English so we can't read it...

    wbr
     
  8. AutomotrizVIP

    AutomotrizVIP ATZ Regular New Member Valued Contributor

    what do you need to translate?
    LEER= read
    Escribir= write
    Identificación de la centralita=Control unit identification
    Guardar ID= save ID
     
  9. Shooting

    Shooting Super Moderator Staff Member

    I've looked at your files and think you have supplied BDM backup and OBD reads.
    The OBD read is 100% and CRC's are fine too, your problem is the Boot mode for BDM.
    You'll need to boot the ECU in bootmode and re-flash the ecu including it's eeprom

    wbr
     
    Johnner likes this.
  10. AutomotrizVIP

    AutomotrizVIP ATZ Regular New Member Valued Contributor

    Hi mate, it's not right, the car doesn't start.
    This is the photo of the Tag....
    An original file for this car would be good...
    I have the ECU in the bank for programming,connected = r120 reset, boot, canH-L, 12v, gnd
     

    Attached Files:

  11. Shooting

    Shooting Super Moderator Staff Member

    You need to reflash using Original read, as this contains your Immo data.
    Unless original read was corrupt you need to use it.

    wbr
     
  12. AutomotrizVIP

    AutomotrizVIP ATZ Regular New Member Valued Contributor

    Attached Files:

  13. Shooting

    Shooting Super Moderator Staff Member

    Your ECU is Tricore and has Immo data in the eeprom, flashing someone elses dump won't work
    Maybe look for an Immo off solution but I have never seen it.

    wbr
     

Share This Page